Page tree
Skip to end of metadata
Go to start of metadata
There is a known issue that manifests during activation and can bring the Java virtual machine down with a segmentation fault. The issue occurs with a combination of Mac OS X, Java and the Tomcat application server versions.

(tick) The issue is fixed in Java SE Development Kit 8 Update 11 (JDK 8u11). Please update your JDK.

 The issue may also occur with versions that are not yet listed below, please report if you find any.

Operating systemProblematic Java versionsProblematic application server versions
Mac OS X

Prior to Java SE Development Kit 8 Update 11

Tomcat 6.*
Tomcat 7.*
JBoss AS 7.* (based on Tomcat 7)

Symptoms

Symptoms that you are running into the issue are:

  • Browser reports a dropped connection. Screenshot
  • The Web update is missing resources such as images. Screenshot
  • JVM crashes and creates a hs_err_pid*.log file.

Find a more detailed description of the issue in Dropped HTTP connections.

In order to prevent users from running into the issue, an install condition stops the installation process and warns you during the Web update if your environment matches the error prone combination MAGNOLIA-5526 - Getting issue details... STATUS

Tickets that report the issue:

  • MAGNOLIA-5520 - Getting issue details... STATUS
  • JDK-8028313 SEGV during java.net.SocketInputStream.socketread0 on mac osx

Fixing

We recommend that you upgrade or downgrade to a version of Java or Tomcat that is outside the error prone combination.

Alternatively, you can continue to work with the combination and disable the install condition by adding the following property to your magnolia.properties file.

magnolia.properties
magnolia.allow.problematic.environment=true