Magnolia 4.5 reached end of life on June 30, 2016. This branch is no longer supported, see End-of-life policy.

Page tree
Skip to end of metadata
Go to start of metadata

What has changed since Magnolia 4.5.11

Magnolia 4.5.12 delivers the following fixes and enhancements:

  • Made the Shop module more robust.
  • Improvements to Form module fields such as honeypot, checkbox and checkbox group.
  • Improvements to the migration process 
    • It is now possible to turn on saving of partially migrated content to preserve memory.
    • Migration module contains a tool for discovering custom code placed inside Magnolia's own modules.
  • Stricter handling of extensions for images.
  • Render type can be now modified for templates via variations.
  • Cache items now differentiate also the method used to retrieve content.
  • The page editor is more resilient to broken HTML markup in pages.

An aggregated change log for 4.5.12 contains all the changes.

This release is a recommended update for all users of Magnolia 4.5.

Updated modules

This release includes the following new module versions:

  • Magnolia CE 4.5.12
  • Magnolia EE 4.5.12
  • Data 1.7.7
  • Extended Templating Kit 2.0.13
  • Form 1.4.9
  • Groovy 1.2.7
  • DMS 1.6.10
  • Imaging 2.2.4
  • Migration 1.2.6
  • NTLM 1.1
  • Resources 1.5.9
  • Shop 1.1.4
  • Standard Templating Kit 2.0.13
  • Tools 1.2.2

The Magnolia team would also like to thank everyone who reported issues, contributed patches, or simply commented on issues for this release. Your continued interest helps us make Magnolia better. Special thanks go to: Joerg von Frantzius, Nils Breunese, Tom Wespi, Rico Jansen, Roman Chernovolov, Frank Sommer, Fatha Idrees and Wolf Bubenik

How to update from Magnolia 4.5.x

Unable to render {include} The included page could not be found.

How to migrate from Magnolia 4.4.7

Migration is your starting point. You should understand that migration is not a simple update but an effort that needs to be planned ahead.

How to migrate from versions prior to 4.4.6

Updating from a version prior to 4.4.6 directly to 4.5.x does not work. You need to first update to 4.4.6, then follow the procedure described in Migration. Finally, follow How to update from Magnolia 4.5.x above.

Known issues

See: Known issues.