Magnolia 4.5 reached end of life on June 30, 2016. This branch is no longer supported, see End-of-life policy.

Page tree
Skip to end of metadata
Go to start of metadata

Released on April 2, 2014

What has changed since Magnolia 4.5.17

Magnolia 4.5.18 delivers the following fixes and enhancements:

  • Fixed an issue where recursive user groups caused a StackOverflowError.
  • Fixed an issue where the system ignored the workspace configured in component definitions.
  • Fixed an issue where the Diff module was not i18n-aware when a single site was served in multiple languages.
  • Added a warning in case a module version handler runs delta tasks that are intended for a future version of the module.
  • Fixed host-based virtual URI mapping so that it selects the best-matching host name regardless of the order in which hosts are configured.
  • Confirmed that the configuration of a Magnolia 4.4.12 instance migrated to 4.5.18 is the same as the configuration of a freshly installed 4.5.18 instance.

Changelog for 4.5.18 contains all changes and details.

This release is a recommended update for all users of Magnolia 4.5.

(info) This is a maintenance release of a previous major version (4.5) of Magnolia, therefore available only to Enterprise clients. Read our maintenance policy for details. The released artifacts are in the magnolia.public.maintenance.releases repository (login required).

Updated modules

This release includes the following new module versions:

  • Magnolia 4.5.18
  • Enterprise Edition 4.5.18
  • Data 1.7.10
  • Diff 1.2.2
  • Extended Templating Kit 2.0.19
  • Google Sitemap 1.2.5
  • RSS Aggregator 1.4.4
  • Standard Templating Kit 2.0.19
  • Tools 1.2.3

The Magnolia team would also like to thank everyone who reported issues, contributed patches, or simply commented on issues for this release. Your continued interest helps us make Magnolia better. Special thanks go to: Tom Wespi, Nils Breunese, Dominik Kunz, Marcel Stör, and Edgar Vonk.

How to update from Magnolia 4.5.x

Follow the standard update process.

How to update from Magnolia 4.4 and earlier

Are you running on Magnolia 4.4 or earlier? It’s time to move to 4.5 and then to 5. Contact us for migration support and look at the migration process.

Known issues

See: Known issues.